środa, 5 marca 2008

Vista a WAMP

W ubiegłym tygodniu próbowałem zainstalować u siebie na komputerze dość standardowy zestaw aplikacji: Apache'a, MySQLa oraz PHP. Stwierdziłem, że skoro lubię mieć kontrolę nad wszystkim, co robię, zainstaluję każdy z tych składników zupełnie osobno i niezależnie.

Apache - poszedł od kopa. PHP - też nie było problemów.
Natomiast MySQL stwierdził, że nie będzie współpracować.
Na początku próbowałem zainstalować wersję bieżącą, czyli 5.0.51a. Cały instalator przeszedł bezproblemowo aż do momentu, gdy należało skonfigurować swój serwer. Wtedy właśnie aplikacja wypisała, co mnie o myśli i nie pozwoliła sobie odpowiedzieć (w okienku dialogowym było tylko "OK"). Po paru chwilach doszedłem, o co chodzi - nie zainstalował się serwis (w sensie usługi Windows).
Próbowałem kilka razy. Próbowałem też zainstalować najnowszą wersję - 5.1.23 Release Candidate Development Release. Też nic. To samo. Nie pomogły nawet ręczne próby zainstalowania serwisu. Ponieważ nie chciałem nawet próbować instalować wersji starszej (4.1) - zrezygnowałem.

Później jednak przeczytałem na pewnym forum, że ktoś poradził sobie z tym problemem instalując AppServ. Jest to bardzo fajny zbiór podobny w założeniach do XAMPP-a czy Krasnala. Instaluje Apache'a (obecnie 2.2.4), PHP (5.2.3), MySQL-a (5.0.45) oraz phpMyAdmina (2.10.2). Ku mojemu zaskoczeniu użycie AppServa pomogło i teraz wszystkie z tych składników działają bez zarzutu.

A jaka była przyczyna problemów? Nie mam zielonego pojęcia.

Brak komentarzy:

Prześlij komentarz